[PATCH] ata: ahci-pci: Replace magic constant by macro

Pali Rohár pali at kernel.org
Sun Dec 4 13:31:08 CET 2022


Replace 0x1b21 by macro PCI_VENDOR_ID_ASMEDIA with the same value.

Signed-off-by: Pali Rohár <pali at kernel.org>
---
 drivers/ata/ahci-pci.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/ata/ahci-pci.c b/drivers/ata/ahci-pci.c
index 797e0d570e88..5356b9d83d34 100644
--- a/drivers/ata/ahci-pci.c
+++ b/drivers/ata/ahci-pci.c
@@ -37,7 +37,7 @@ U_BOOT_DRIVER(ahci_pci) = {
 
 static struct pci_device_id ahci_pci_supported[] = {
 	{ PCI_DEVICE_CLASS(PCI_CLASS_STORAGE_SATA_AHCI, ~0) },
-	{ PCI_DEVICE(0x1b21, 0x0611) },
+	{ PCI_DEVICE(PCI_VENDOR_ID_ASMEDIA, 0x0611) },
 	{ PCI_DEVICE(PCI_VENDOR_ID_MARVELL, 0x6121) },
 	{ PCI_DEVICE(PCI_VENDOR_ID_MARVELL, 0x6145) },
 	{},
-- 
2.20.1



More information about the U-Boot mailing list