[PATCH 2/5] video console: refactoring and optimization

Simon Glass sjg at chromium.org
Thu Dec 29 23:39:09 CET 2022


Hi Dzmitry,

On Mon, 26 Dec 2022 at 13:50, Dzmitry Sankouski <dsankouski at gmail.com> wrote:
>
> - get rid of code duplications in switch across bpp values
> - extract common pixel fill logic in two functions one per
> horizontal and vertical filling
> - rearrange statements in put_xy* methods in unified way
> - replace types - uint*_t to u*
>
> Signed-off-by: Dzmitry Sankouski <dsankouski at gmail.com>
> ---
>  drivers/video/console_simple.c | 508 ++++++++++++---------------------
>  1 file changed, 184 insertions(+), 324 deletions(-)

This looks like a nice tidy up.

Is there a code-size or performance penalty with this? E.g. with
CONFIG_CONSOLE_ROTATION disabled

Please can you comment the functions property so we know what they do?

Regards,
Simon


More information about the U-Boot mailing list