[PATCH] usb: dwc3: Fix renaming SPL_USB_HOST_SUPPORT to SPL_USB_HOST

Tom Rini trini at konsulko.com
Wed Aug 23 19:11:21 CEST 2023


On Wed, Aug 23, 2023 at 05:22:19PM +0300, Oleksandr Suvorov wrote:

> In the usb/dwc3-layerscape driver the first option should be renamed
> to the latter as well. Do it.
> 
> Fixes: 333e4a621df ("Rename SPL_USB_HOST_SUPPORT to SPL_USB_HOST")
> Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov at foundries.io>
> ---
> 
>  drivers/usb/dwc3/dwc3-layerscape.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/usb/dwc3/dwc3-layerscape.c b/drivers/usb/dwc3/dwc3-layerscape.c
> index 79cf71f7a85..77801c10084 100644
> --- a/drivers/usb/dwc3/dwc3-layerscape.c
> +++ b/drivers/usb/dwc3/dwc3-layerscape.c
> @@ -134,7 +134,7 @@ U_BOOT_DRIVER(dwc3_layerscape_peripheral) = {
>  };
>  #endif
>  
> -#if defined(CONFIG_SPL_USB_HOST_SUPPORT) || \
> +#if defined(CONFIG_SPL_USB_HOST) || \
>  	!defined(CONFIG_SPL_BUILD) && defined(CONFIG_USB_HOST)
>  static int dwc3_layerscape_host_probe(struct udevice *dev)
>  {
> @@ -194,7 +194,7 @@ static int dwc3_layerscape_bind(struct udevice *dev)
>  		driver = "dwc3-layerscape-peripheral";
>  		break;
>  #endif
> -#if defined(CONFIG_SPL_USB_HOST_SUPPORT) || !defined(CONFIG_SPL_BUILD)
> +#if defined(CONFIG_SPL_USB_HOST) || !defined(CONFIG_SPL_BUILD)
>  	case USB_DR_MODE_HOST:
>  		dev_dbg(dev, "Using host mode\n");
>  		driver = "dwc3-layerscape-host";

This is incomplete as now that we have CONFIG_SPL_USB_HOST instead of
CONFIG_SPL_USB_HOST_SUPPORT that means we can use
CONFIG_IS_ENABLED(USB_HOST) which is true for (SPL_BUILD&&SPL_USB_HOST) ||
(!SPL_BUILD&&USB_HOST).

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20230823/9c2e68de/attachment.sig>


More information about the U-Boot mailing list