[PATCH v2] usb: dwc3: Fix renaming SPL_USB_HOST_SUPPORT to SPL_USB_HOST
Marek Vasut
marex at denx.de
Wed Aug 23 20:29:44 CEST 2023
On 8/23/23 20:21, Oleksandr Suvorov wrote:
> In the usb/dwc3-layerscape driver the first option should be renamed
> to the latter as well. Do it.
>
> Fixes: 333e4a621df ("Rename SPL_USB_HOST_SUPPORT to SPL_USB_HOST")
> Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov at foundries.io>
> ---
>
> Changes in v2:
> - [asked by Tom Rini] shrink the code using CONFIG_IS_ENABLED()
>
> drivers/usb/dwc3/dwc3-layerscape.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/usb/dwc3/dwc3-layerscape.c b/drivers/usb/dwc3/dwc3-layerscape.c
> index 79cf71f7a85..58baa017ad1 100644
> --- a/drivers/usb/dwc3/dwc3-layerscape.c
> +++ b/drivers/usb/dwc3/dwc3-layerscape.c
> @@ -134,8 +134,7 @@ U_BOOT_DRIVER(dwc3_layerscape_peripheral) = {
> };
> #endif
>
> -#if defined(CONFIG_SPL_USB_HOST_SUPPORT) || \
> - !defined(CONFIG_SPL_BUILD) && defined(CONFIG_USB_HOST)
> +#if CONFIG_IS_ENABLED(USB_HOST)
> static int dwc3_layerscape_host_probe(struct udevice *dev)
> {
> struct xhci_hcor *hcor;
> @@ -194,7 +193,7 @@ static int dwc3_layerscape_bind(struct udevice *dev)
> driver = "dwc3-layerscape-peripheral";
> break;
> #endif
> -#if defined(CONFIG_SPL_USB_HOST_SUPPORT) || !defined(CONFIG_SPL_BUILD)
> +#if defined(CONFIG_SPL_USB_HOST) || !defined(CONFIG_SPL_BUILD)
Why not CONFIG_IS_ENABLED(USB_HOST) here too ?
More information about the U-Boot
mailing list