[PATCH V4 8/8] doc: board: ti: Add BeaglePlay documentation

Simon Glass sjg at google.com
Sat Aug 26 04:04:29 CEST 2023

Hi Robert,

On Fri, 25 Aug 2023 at 19:06, Robert Nelson <robertcnelson at gmail.com> wrote:
> > > Just https://etcher.balena.io/ and flash an SD card with the official
> > > image here: https://www.beagleboard.org/distros/beagleplay-debian-11-flasher
> > >
> > > https://files.beagle.cc/file/beagleboard-public-2021/images/am625x-emmc-flasher-debian-11.6-xfce-arm64-2023-02-04-10gb.img.xz
> >
> > OK I tried that on an SD card, but it is still bricked.
> >
> Hi Simon,
> I've found the bootrom can be a little too quick and you'll get stuck
> on a failed eMMC bootloader.
> I find it best, with power applied, if you hold both the USR and RESET
> buttons down, then lift off the RESET button.. This will ensure the
> bootrom/sysboot will actually load the microSD's version of u-boot.
> If it's still failing, please grab this newer small August release:
> That's posted here:
> https://forum.beagleboard.org/t/arm64-debian-11-x-bullseye-monthly-snapshots-2023-08-05/32318
>  (updated monthly)
> Specifically this flasher file:
> https://rcn-ee.com/rootfs/release/2023-08-05/bullseye-minimal-arm64/beagleplay-emmc-flasher-debian-11.7-minimal-arm64-2023-08-05-4gb.img.xz
> Use Balena Etcher to write it directly to a microSD.
> Insert microSD in
> Apply Power (leds should turn on, if not hit the PWR button to wake up
> the TPS...)
> Next, hold both USR and RESET buttons
> Now, Lift off only the RESET button
> When even more leds turn on, lift up on the USR button.
> At this point the serial should be loading/booting linux, and then
> running the eMMC flasher in single user mode.  Within 5 minutes or so,
> it should shutdown with a new image in the eMMC..

Thank you, that worked!


More information about the U-Boot mailing list