[PATCH 00/13] Complete decoupling of zboot logic from commands

Simon Glass sjg at chromium.org
Mon Dec 4 01:29:25 CET 2023


This series refactors the zboot code to allow it to be used with
CONFIG_COMMAND disabled.

A new zboot_run() function is used to boot a zimage.

This is cmde (part e of CMDLINE refactoring)
It depends on dm/cmdd-working
which depends on dm/bootstda-working
which depends on dm/cmdc-working


Simon Glass (13):
  x86: zboot: Move zimage definitions to the header file
  x86: zboot: Move command code into its own file
  x86: zboot: Create a separate ZBOOT option for zboot logic
  x86: zboot: Avoid iteration in do_zboot_states()
  x86: zboot: Create separate functions for the logic
  x86: zboot: Move environment setting into zboot_load()
  x86: zboot: Drop intermediate zboot_setup() function
  x86: zboot: Drop intermediate zboot_go() function
  x86: zboot: Move argument processing outside zboot_start()
  x86: zboot: Rename zboot_start() to zboot_run()
  x86: zboot: Separate logic functions from commands
  x86: zboot: Use zboot_start() in zboot_run()
  x86: zboot: Tidy up the comment for zboot_run()

 arch/Kconfig                  |   1 -
 arch/x86/Kconfig              |   8 +
 arch/x86/include/asm/zimage.h |  97 ++++++++++++
 arch/x86/lib/Makefile         |   2 +-
 arch/x86/lib/zimage.c         | 267 ++++------------------------------
 boot/bootmeth_cros.c          |   6 +-
 cmd/Kconfig                   |   2 +
 cmd/x86/Makefile              |   1 +
 cmd/x86/zboot.c               | 182 +++++++++++++++++++++++
 include/bootm.h               |  15 +-
 10 files changed, 333 insertions(+), 248 deletions(-)
 create mode 100644 cmd/x86/zboot.c

-- 
2.43.0.rc2.451.g8631bc7472-goog



More information about the U-Boot mailing list