[PATCH v4 00/12] Support Firmware Handoff spec via bloblist

Raymond Mao raymond.mao at linaro.org
Wed Dec 27 22:06:58 CET 2023


Major changes:

Update bloblist to align to Firmware Handoff spec v0.9
(up to commit #3592349 of the spec).
(https://github.com/FirmwareHandoff/firmware_handoff).

Includes:
- Align bloblist tags with the FW handoff spec
- Add an explicit alignment field in the header
- Update bloblist magic and version
- Use a packed format for blob record header
- Change the checksum alorigthm
- Use a void entry to handle the alignment
- Adjust the headers of bloblist and blob record
- Align the bloblist record data section start address

>From v3, the implementation from boot arguments to bloblist and how to
load the FDT from the bloblist are moved to a forthcoming patch serie.

In v4, patch #7 and #14 from v3 are squashed.

Simon Glass (12):
  bloblist: Update the tag numbering
  bloblist: Adjust API to align in powers of 2
  bloblist: Change the magic value
  bloblist: Set version to 1
  bloblist: Access record hdr_size and tag via a function
  bloblist: Drop spare value from bloblist record
  bloblist: Checksum the entire bloblist
  bloblist: Handle alignment with a void entry
  bloblist: Reduce blob-header size
  bloblist: Adjust the bloblist header
  bloblist: Add alignment to bloblist_new()
  bloblist: Update documentation and header comment

 arch/x86/lib/tables.c    |   3 +-
 common/bloblist.c        | 205 ++++++++++++++++++++++++---------------
 doc/develop/bloblist.rst |   4 +-
 include/bloblist.h       | 166 ++++++++++++++++++-------------
 test/bloblist.c          | 105 +++++++++++---------
 5 files changed, 287 insertions(+), 196 deletions(-)

-- 
2.25.1



More information about the U-Boot mailing list