[PATCH v3 2/9] video console: refactoring and optimization

Simon Glass sjg at chromium.org
Thu Feb 16 00:49:50 CET 2023


On Wed, 15 Feb 2023 at 04:44, Dzmitry Sankouski <dsankouski at gmail.com> wrote:
>
> - get rid of code duplications in switch across bpp values
> - extract common pixel fill logic in two functions one per
> horizontal and vertical filling
> - rearrange statements in put_xy* methods in unified way
> - replace types - uint*_t to u*
>
> Signed-off-by: Dzmitry Sankouski <dsankouski at gmail.com>
> ---
> Changes for v2:
> - move width and pixel data size macros to console_simple.c
> - performance: move if statement out of pixel fill loops
> - document new functions
> - remove console_probe_2 function
> - make fill_pixel_and_goto_next void
> - fix video unit tests failures
> Changes for v3: none
>
>  drivers/video/console_simple.c | 598 ++++++++++++++-------------------
>  1 file changed, 258 insertions(+), 340 deletions(-)

Reviewed-by: Simon Glass <sjg at chromium.org>


More information about the U-Boot mailing list