[PATCH v2 1/6] binman: Add support for a rockchip-tpl entry
Jonas Karlman
jonas at kwiboo.se
Thu Feb 16 15:02:15 CET 2023
Hi Eugen,
On 2023-02-16 12:26, Eugen Hristev wrote:
> On 2/14/23 12:33, Jonas Karlman wrote:
>> The rockchip-tpl entry can be used when an external TPL binary should be
>> used instead of the normal U-Boot TPL.
>>
>> Signed-off-by: Jonas Karlman <jonas at kwiboo.se>
>> ---
>> v2:
>> - rename external-tpl to rockchip-tpl
>> - missing message moved to this patch
>>
>> tools/binman/entries.rst | 14 ++++++++++++++
>> tools/binman/etype/rockchip_tpl.py | 20 ++++++++++++++++++++
>> tools/binman/ftest.py | 7 +++++++
>> tools/binman/missing-blob-help | 5 +++++
>> tools/binman/test/277_rockchip_tpl.dts | 16 ++++++++++++++++
>> 5 files changed, 62 insertions(+)
>> create mode 100644 tools/binman/etype/rockchip_tpl.py
>> create mode 100644 tools/binman/test/277_rockchip_tpl.dts
>
> Hi Jonas,
>
> Is it possible to add the filename 'rockchip-tpl' to gitignore, such
> that it won't show up all the time when you do git status ?
> (in the case where you place the rockchip-tpl in the same dir )
You should not need to name the file 'rockchip-tpl', instead of placing a
file in your u-boot folder, use the ROCKCHIP_TPL env variable like:
export BL31=../rkbin/bin/rk35/rk3588_bl31_v1.36.elf
export ROCKCHIP_TPL=../rkbin/bin/rk35/rk3588_ddr_lp4_2112MHz_lp5_2736MHz_v1.09.bin
make
or possible a make argument:
make ROCKCHIP_TPL=../rkbin/bin/rk35/rk3588_ddr_lp4_2112MHz_lp5_2736MHz_v1.09.bin
Regards,
Jonas
>
> Otherwise, I tested your series:
>
> Tested-by: Eugen Hristev <eugen.hristev at collabora.com>
>
> Eugen
More information about the U-Boot
mailing list