[PATCH v5 1/1] video console: refactoring and optimization

Simon Glass sjg at chromium.org
Tue Feb 21 17:00:55 CET 2023


On Mon, 20 Feb 2023 at 03:49, Dzmitry Sankouski <dsankouski at gmail.com> wrote:
>
> - move common code to vidconsole_internal.h and console_core.c
> - unite probe functions
> - get rid of code duplications in switch across bpp values
> - extract common pixel fill logic in two functions one per
> horizontal and vertical filling
> - rearrange statements in put_xy* methods in unified way
> - replace types - uint*_t to u*
>
> Signed-off-by: Dzmitry Sankouski <dsankouski at gmail.com>
> ---
> Changes for v2: none
> Changes for v3: none
> Changes for v4:
> - move common code to vidconsole_internal.h
> - unite probe functions
> Changes for v5:
> - move common functions to console-core.c file
> - remove static keyword from shared functions
>
>  drivers/video/Makefile              |   6 +
>  drivers/video/console_core.c        | 141 +++++++++++++
>  drivers/video/console_normal.c      | 150 ++++----------
>  drivers/video/console_rotate.c      | 308 ++++------------------------
>  drivers/video/vidconsole_internal.h |  95 +++++++++
>  5 files changed, 324 insertions(+), 376 deletions(-)
>  create mode 100644 drivers/video/console_core.c
>  create mode 100644 drivers/video/vidconsole_internal.h

Reviewed-by: Simon Glass <sjg at chromium.org>


More information about the U-Boot mailing list