[PATCH 11/19] usb: musb: Rename CONFIG_USB_MUSB_TIMEOUT to MUSB_TIMEOUT

Tom Rini trini at konsulko.com
Tue Jan 10 17:19:38 CET 2023


This variable has never been configured to another value at present, and
was not converted to Kconfig. Opt instead to rename this to
MUSB_TIMEOUT.

Cc: Marek Vasut <marex at denx.de>
Signed-off-by: Tom Rini <trini at konsulko.com>
---
 drivers/usb/musb/musb_hcd.c | 6 +++---
 drivers/usb/musb/musb_hcd.h | 4 +---
 2 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/drivers/usb/musb/musb_hcd.c b/drivers/usb/musb/musb_hcd.c
index 17901704f521..4676cabae0aa 100644
--- a/drivers/usb/musb/musb_hcd.c
+++ b/drivers/usb/musb/musb_hcd.c
@@ -118,7 +118,7 @@ static int wait_until_ep0_ready(struct usb_device *dev, u32 bit_mask)
 {
 	u16 csr;
 	int result = 1;
-	int timeout = CONFIG_USB_MUSB_TIMEOUT;
+	int timeout = MUSB_TIMEOUT;
 
 	while (result > 0) {
 		csr = readw(&musbr->txcsr);
@@ -180,7 +180,7 @@ static int wait_until_ep0_ready(struct usb_device *dev, u32 bit_mask)
 static int wait_until_txep_ready(struct usb_device *dev, u8 ep)
 {
 	u16 csr;
-	int timeout = CONFIG_USB_MUSB_TIMEOUT;
+	int timeout = MUSB_TIMEOUT;
 
 	do {
 		if (check_stall(ep, 1)) {
@@ -212,7 +212,7 @@ static int wait_until_txep_ready(struct usb_device *dev, u8 ep)
 static int wait_until_rxep_ready(struct usb_device *dev, u8 ep)
 {
 	u16 csr;
-	int timeout = CONFIG_USB_MUSB_TIMEOUT;
+	int timeout = MUSB_TIMEOUT;
 
 	do {
 		if (check_stall(ep, 0)) {
diff --git a/drivers/usb/musb/musb_hcd.h b/drivers/usb/musb/musb_hcd.h
index 7eb65e6b10d0..a492e99ef9d1 100644
--- a/drivers/usb/musb/musb_hcd.h
+++ b/drivers/usb/musb/musb_hcd.h
@@ -16,9 +16,7 @@
 extern unsigned char new[];
 #endif
 
-#ifndef CONFIG_USB_MUSB_TIMEOUT
-# define CONFIG_USB_MUSB_TIMEOUT 100000
-#endif
+#define MUSB_TIMEOUT 100000
 
 /* This defines the endpoint number used for control transfers */
 #define MUSB_CONTROL_EP 0
-- 
2.25.1



More information about the U-Boot mailing list