[PATCH v7 01/10] video console: refactoring and optimization

Anatolij Gustschin agust at denx.de
Wed Mar 1 23:24:36 CET 2023


Hi Dzmitry,

On Mon, 27 Feb 2023 20:37:01 +0300
Dzmitry Sankouski dsankouski at gmail.com wrote:

> - move common code to vidconsole_internal.h and console_core.c
> - unite probe functions
> - get rid of code duplications in switch across bpp values
> - extract common pixel fill logic in two functions one per
> horizontal and vertical filling
> - rearrange statements in put_xy* methods in unified way
> - replace types - uint*_t to u*
> 
> Signed-off-by: Dzmitry Sankouski <dsankouski at gmail.com>
> Reviewed-by: Simon Glass <sjg at chromium.org>
> ---
> Changes for v2: none
> Changes for v3: none
> Changes for v4:
> - move common code to vidconsole_internal.h
> - unite probe functions
> Changes for v5:
> - move common functions to console-core.c file
> - remove static keyword from shared functions
> Changes for v6: none
> Changes for v7: none
> 
>  drivers/video/Makefile              |   6 +
>  drivers/video/console_core.c        | 141 +++++++++++++

Building console_core.c fails for board configs without CONFIG_VIDEO_COPY,
i.e.:

  https://source.denx.de/u-boot/custodians/u-boot-video/-/jobs/587261

I fixed it for further build testing by additionally applying:

diff --git a/include/video_console.h b/include/video_console.h
index 9d2c0f210e..3e1e00c23f 100644
--- a/include/video_console.h
+++ b/include/video_console.h
@@ -340,6 +340,9 @@ int vidconsole_sync_copy(struct udevice *dev, void *from, void *to);
 int vidconsole_memmove(struct udevice *dev, void *dst, const void *src,
                       int size);
 #else
+
+#include <string.h>
+
 static inline int vidconsole_sync_copy(struct udevice *dev, void *from,
                                       void *to)
 {


--
Anatolij


More information about the U-Boot mailing list