[PATCH v2 13/32] test: cmd: fdt: Rename fdt_test_get() to fdt_test_get_value()

Marek Vasut marek.vasut+renesas at mailbox.org
Thu Mar 2 04:08:26 CET 2023

The 'fdt get' command has a 'get value' subcommand, rename the fdt_test_get()
to fdt_test_get_value() to avoid confusion about what it is testing. There is
currently no get 'get name', 'get addr', 'get size' subcommand test.

Signed-off-by: Marek Vasut <marek.vasut+renesas at mailbox.org>
Reviewed-by: Simon Glass <sjg at chromium.org>
Cc: Heinrich Schuchardt <heinrich.schuchardt at canonical.com>
Cc: Simon Glass <sjg at chromium.org>
Cc: Tom Rini <trini at konsulko.com>
V2: Add RB from Simon
 test/cmd/fdt.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/test/cmd/fdt.c b/test/cmd/fdt.c
index a50285eafab..03a29c6b9c0 100644
--- a/test/cmd/fdt.c
+++ b/test/cmd/fdt.c
@@ -142,8 +142,8 @@ static int fdt_test_addr_resize(struct unit_test_state *uts)
 FDT_TEST(fdt_test_addr_resize, UT_TESTF_CONSOLE_REC);
-/* Test 'fdt get' reading an fdt */
-static int fdt_test_get(struct unit_test_state *uts)
+/* Test 'fdt get value' reading an fdt */
+static int fdt_test_get_value(struct unit_test_state *uts)
 	ulong addr;
@@ -193,7 +193,7 @@ static int fdt_test_get(struct unit_test_state *uts)
 	return 0;
+FDT_TEST(fdt_test_get_value, UT_TESTF_CONSOLE_REC);
 int do_ut_fdt(struct cmd_tbl *cmdtp, int flag, int argc, char *const argv[])

More information about the U-Boot mailing list