No such file or directory: lxdialog/dialog.h

Nick Carraway 1800ponysauce at
Thu Mar 2 02:19:24 CET 2023


Apologies to bother y'all with this. I am at wit's end. I think this
is an issue that I've encountered before and figured out how to solve,
but I can't for the life of me figure out what to do this time around.

Whenever I try to `make O=../generic-build menuconfig` from my u-boot
build directory, I get this error:

"Error: No such file or directory: lxdialog/dialog.h" in line 22 the
file scripts/kconfig/mconf.c. It's one of the first parts of the
menuconfig issues.

This error occurs on Debian bullseye and Debian buster! And I'm pretty
sure it was working before, because I have successful builds from the
2021-10-rc5. But even when I git rollback to that one, I still get the
error. I thought it was my build environment until I switched machines
and got the same result! Both machines run arm64 - is that the issue??

I went into the library paths. One of the machines has a "dialog.h"
header, but it's not in the "lxdialog/dialog.h" header. How do I get
this library?? I'm so confused.

Bullseye and buster both have libncurses5 and 6, w5, and w6, but
nothing beyond that. I say this because this is what most search
engines seem to hint that the problem is. I think this is not really a
dependency error though, and something else is going on. I really just
don't know what the problem is because this code was working about a
year ago and nothing on the machine changed, but now I can't figure
out what I did to make it work!

More information about the U-Boot mailing list