No such file or directory: lxdialog/dialog.h

Nick Carraway 1800ponysauce at
Thu Mar 2 18:02:36 CET 2023

Here is the full output with V=1:

make -C /home/user/user-u-boot/generic-build
KBUILD_SRC=/home/user/user-u-boot/generic-raw \
-f /home/user/user-u-boot/generic-raw/Makefile menuconfig
make[1]: Entering directory '/home/user/user-u-boot/generic-build'
make -f /home/user/user-u-boot/generic-raw/scripts/
rm -f .tmp_quiet_recordmcount
ln -fsn /home/user/user-u-boot/generic-raw source
/bin/bash /home/user/user-u-boot/generic-raw/scripts/mkmakefile
  GEN     Makefile
make -f /home/user/user-u-boot/generic-raw/scripts/
obj=scripts/kconfig menuconfig
set -e; mkdir -p scripts/kconfig/;      /bin/bash
/home/user/user-u-boot/generic-raw/scripts/kconfig/ <
/home/user/user-u-boot/generic-raw/scripts/kconfig/ >
scripts/kconfig/.mconf-cfg.tmp; if [ -r scripts/kconfig/.mconf-cfg ]
&& cmp -s scripts/kconfig/.mconf-cfg scripts/kconfig/.mconf-cfg.tmp;
then rm -f scripts/kconfig/.mconf-cfg.tmp; else : '  UPD
scripts/kconfig/.mconf-cfg'; mv -f scripts/kconfig/.mconf-cfg.tmp
scripts/kconfig/.mconf-cfg; fi
  cc -Wp,-MD,scripts/kconfig/.mconf.o.d -Iscripts/kconfig -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu11
-D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600 -c -o scripts/kconfig/mconf.o
fatal error: lxdialog/dialog.h: No such file or directory
   22 | #include "lxdialog/dialog.h"
      |          ^~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [scripts/ scripts/kconfig/mconf.o] Error 1
make[1]: *** [/home/user/user-u-boot/generic-raw/Makefile:569:
menuconfig] Error 2
make[1]: Leaving directory '/home/user/user-u-boot/generic-build'
make: *** [Makefile:177: sub-make] Error 2

On Thu, Mar 2, 2023 at 10:52 AM Tom Rini <trini at> wrote:
> On Wed, Mar 01, 2023 at 08:19:24PM -0500, Nick Carraway wrote:
> > Hello!
> >
> > Apologies to bother y'all with this. I am at wit's end. I think this
> > is an issue that I've encountered before and figured out how to solve,
> > but I can't for the life of me figure out what to do this time around.
> >
> > Whenever I try to `make O=../generic-build menuconfig` from my u-boot
> > build directory, I get this error:
> >
> > "Error: No such file or directory: lxdialog/dialog.h" in line 22 the
> > file scripts/kconfig/mconf.c. It's one of the first parts of the
> > menuconfig issues.
> >
> > This error occurs on Debian bullseye and Debian buster! And I'm pretty
> > sure it was working before, because I have successful builds from the
> > 2021-10-rc5. But even when I git rollback to that one, I still get the
> > error. I thought it was my build environment until I switched machines
> > and got the same result! Both machines run arm64 - is that the issue??
> >
> > I went into the library paths. One of the machines has a "dialog.h"
> > header, but it's not in the "lxdialog/dialog.h" header. How do I get
> > this library?? I'm so confused.
> >
> > Bullseye and buster both have libncurses5 and 6, w5, and w6, but
> > nothing beyond that. I say this because this is what most search
> > engines seem to hint that the problem is. I think this is not really a
> > dependency error though, and something else is going on. I really just
> > don't know what the problem is because this code was working about a
> > year ago and nothing on the machine changed, but now I can't figure
> > out what I did to make it work!
> I have a feeling there's something funny going on with your system, but,
> a "V=1" passed to make will at least start showing you what/where gcc is
> looking.
> --
> Tom

More information about the U-Boot mailing list