Please pull u-boot-dm

Simon Glass sjg at chromium.org
Fri Mar 10 21:54:57 CET 2023


Hi Tom,

https://source.denx.de/u-boot/custodians/u-boot-dm/-/pipelines/15515

Marek pointed out that these are bug fixes and tests so should
probably go into -master.

The following changes since commit b08ffdffdce95e267e782366f4a77bf6b5537b28:

  Merge https://source.denx.de/u-boot/custodians/u-boot-marvell
(2023-03-06 14:56:05 -0500)

are available in the Git repository at:

  git://git.denx.de/u-boot-dm.git tags/dm-pull-10mar23

for you to fetch changes up to aa89aebb17531a3e8b6729c812a68d5e37008730:

  test: cmd: fdt: Test fdt bootcpu (2023-03-09 08:50:48 -0800)

----------------------------------------------------------------
fixes and tests for the fdt command

----------------------------------------------------------------
Marek Vasut (25):
      cmd: fdt: Import is_printable_string() from DTC to fix u32 misprint
      cmd: fdt: Fix handling of empty properties for fdt get addr and
fdt get size
      cmd: fdt: Fix fdt rm behavior on non-existent property and error
message space
      cmd: fdt: Fix fdt rsvmem behavior on non-existent index and
error message space
      cmd: fdt: Check argc before accessing argv in fdt bootcpu
      cmd: fdt: Check argc before accessing argv in fdt memory
      cmd: fdt: Align checksign parameter names in help text
      cmd: fdt: Handle 64bit pointers in fdt get addr
      cmd: fdt: Map address returned from fdt get addr to sysmem
      cmd: fdt: Add support for integer arrays in fdt get value with index
      test: Add ut_assert_nextline_empty() empty line helper
      test: cmd: fdt: Rename fdt_test_resize() to fdt_test_addr_resize()
      test: cmd: fdt: Rename fdt_test_get() to fdt_test_get_value()
      test: cmd: fdt: Generate fuller DT internally and switch fdt get
value to it
      test: cmd: fdt: Test alias resolution in 'fdt get value'
      test: cmd: fdt: Test both string and integer arrays in 'fdt get value'
      test: cmd: fdt: Test fdt move
      test: cmd: fdt: Test fdt resize
      test: cmd: fdt: Test fdt get name
      test: cmd: fdt: Test fdt get addr
      test: cmd: fdt: Test fdt get size
      test: cmd: fdt: Test fdt set
      test: cmd: fdt: Test fdt mknode
      test: cmd: fdt: Test fdt rm
      test: cmd: fdt: Test fdt bootcpu

 cmd/fdt.c         |  98 +++++++-----
 include/test/ut.h |   4 +
 test/cmd/fdt.c    | 815
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++---
 3 files changed, 852 insertions(+), 65 deletions(-)

Regards,
Simon


More information about the U-Boot mailing list