[PATCH v2 16/29] net: bootp: Move port numbers to header
Heinrich Schuchardt
xypron.glpk at gmx.de
Sat Oct 14 23:20:31 CEST 2023
Am 14. Oktober 2023 22:47:52 MESZ schrieb Sean Anderson <seanga2 at gmail.com>:
>These defines are useful when testing bootp.
>
>Signed-off-by: Sean Anderson <seanga2 at gmail.com>
>Reviewed-by: Simon Glass <sjg at chromium.org>
>Reviewed-by: Heinrich Schuchardt <xypron.glpk at gmx.de>
>---
>
>(no changes since v1)
>
> net/bootp.c | 3 ---
> net/bootp.h | 3 +++
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
>diff --git a/net/bootp.c b/net/bootp.c
>index 8b1a4ae2ef8..2053cce88c6 100644
>--- a/net/bootp.c
>+++ b/net/bootp.c
>@@ -41,9 +41,6 @@
> */
> #define TIMEOUT_MS ((3 + (CONFIG_NET_RETRY_COUNT * 5)) * 1000)
>
>-#define PORT_BOOTPS 67 /* BOOTP server UDP port */
>-#define PORT_BOOTPC 68 /* BOOTP client UDP port */
>-
> #ifndef CFG_DHCP_MIN_EXT_LEN /* minimal length of extension list */
> #define CFG_DHCP_MIN_EXT_LEN 64
> #endif
>diff --git a/net/bootp.h b/net/bootp.h
>index 567340ec5d4..4e32b19d424 100644
>--- a/net/bootp.h
>+++ b/net/bootp.h
>@@ -15,6 +15,9 @@
>
> /**********************************************************************/
>
>+#define PORT_BOOTPS 67 /* BOOTP server UDP port */
Reading code I would have a hard time to immediately see what this constant name stands for.
Shouldn't this be renamed BOOTP_SERVER_PORT to create readable code?
Regards Heinrich
>+#define PORT_BOOTPC 68 /* BOOTP client UDP port */
>+
> /*
> * BOOTP header.
> */
More information about the U-Boot
mailing list