[PATCH 1/1] net: dw_eth_qos: Add missing \n in error messages.

Heinrich Schuchardt heinrich.schuchardt at canonical.com
Tue Apr 2 13:55:54 CEST 2024


On 02.04.24 13:26, Quentin Schulz wrote:
> Hi Heinrich,
> 
> On 4/2/24 10:39, Heinrich Schuchardt wrote:
>> Missing line-feeds in error messages lead to output like:
>>
>>      phy_startup() failed: -110FAILED: -110=>
>>
>> Output like the following is much easier to read:
>>
>>      phy_startup() failed: -110
>>      FAILED: -110
>>      =>
>>
>> Signed-off-by: Heinrich Schuchardt <heinrich.schuchardt at canonical.com>
>> ---
>>   drivers/net/dwc_eth_qos.c | 108 +++++++++++++++++++-------------------
>>   1 file changed, 54 insertions(+), 54 deletions(-)
>>
>> diff --git a/drivers/net/dwc_eth_qos.c b/drivers/net/dwc_eth_qos.c
>> index 9b3bce1dc87..1b4d0eda887 100644
>> --- a/drivers/net/dwc_eth_qos.c
>> +++ b/drivers/net/dwc_eth_qos.c
>> @@ -159,7 +159,7 @@ static int eqos_mdio_read(struct mii_dev *bus, int 
>> mdio_addr, int mdio_devad,
>>       ret = eqos_mdio_wait_idle(eqos);
>>       if (ret) {
>> -        pr_err("MDIO not idle at entry");
>> +        pr_err("MDIO not idle at entry\n");
> 
> What about using this as an opportunity to migrate to dev_err? 
> (considering there are two GMAC controllers on RK3588(s), this would 
> help identify which has an issue :) ).
> 

I have a dislike for mangling different changes into the same patch.

Please, consider providing a separate patch.

We might also want to get rid of references to __func__ as the log 
framework allows to print function names.

In the example above we might prefer to eliminate writing the same 
information twice.

Best regards

Heinrich



More information about the U-Boot mailing list