[PATCH 1/3] gpio: at91: Implement GPIOF_FUNC in get_function()

Zixun LI admin at hifiphile.com
Tue Nov 12 16:57:10 CET 2024


Hello,


On Tue, Nov 12, 2024 at 2:13 PM Eugen Hristev <eugen.hristev at linaro.org> wrote:
>
>
> > +static bool at91_get_port_pio(struct at91_port *at91_port, int offset)
>
> The name get_port_pio is a bit confusing, can you rename it to something
> more meaningful, like maybe is_periph_func or something ?

How about at91_is_port_pio_active, more inline to the datasheet.


More information about the U-Boot mailing list