[PATCH 7/9] net: ksz9477: rename ksz_i2c_probe() to ksz_probe()
Romain Naour
romain.naour at smile.fr
Tue Oct 8 09:54:30 CEST 2024
In order to support management bus other than the I2C, rename
ksz_i2c_probe() to ksz_probe() since this function is no longer
specific to the I2C bus.
Signed-off-by: Romain Naour <romain.naour at smile.fr>
---
drivers/net/ksz9477.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/drivers/net/ksz9477.c b/drivers/net/ksz9477.c
index f24bf9943e7..82db533c4ec 100644
--- a/drivers/net/ksz9477.c
+++ b/drivers/net/ksz9477.c
@@ -576,10 +576,7 @@ static bool dsa_ksz_check_ops(struct ksz_phy_ops *phy_ops)
return true;
}
-/*
- * I2C driver
- */
-static int ksz_i2c_probe(struct udevice *dev)
+static int ksz_probe(struct udevice *dev)
{
struct dsa_pdata *pdata = dev_get_uclass_plat(dev);
struct ksz_dsa_priv *priv = dev_get_priv(dev);
@@ -678,7 +675,7 @@ U_BOOT_DRIVER(ksz) = {
.name = "ksz-switch",
.id = UCLASS_DSA,
.of_match = ksz_ids,
- .probe = ksz_i2c_probe,
+ .probe = ksz_probe,
.ops = &ksz_dsa_ops,
.priv_auto = sizeof(struct ksz_dsa_priv),
};
--
2.45.0
More information about the U-Boot
mailing list