[PATCH 13/21] test: Move str_ut test into lib
Simon Glass
sjg at chromium.org
Mon Oct 28 13:41:18 CET 2024
This test doesn't belong at the top level. Move it into the lib/
directory, to match (most of) its implementation. Rename it to drop the
unnecessary _ut suffix.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
test/Makefile | 1 -
test/lib/Makefile | 1 +
test/{str_ut.c => lib/str.c} | 0
3 files changed, 1 insertion(+), 1 deletion(-)
rename test/{str_ut.c => lib/str.c} (100%)
diff --git a/test/Makefile b/test/Makefile
index 9f19bfa472b..220a249c397 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -14,7 +14,6 @@ endif
ifneq ($(CONFIG_HUSH_PARSER),)
obj-$(CONFIG_$(XPL_)CMDLINE) += hush/
endif
-obj-$(CONFIG_$(XPL_)CMDLINE) += str_ut.o
obj-$(CONFIG_UT_TIME) += time_ut.o
obj-y += ut.o
diff --git a/test/lib/Makefile b/test/lib/Makefile
index ce22780eed8..be20bbc047f 100644
--- a/test/lib/Makefile
+++ b/test/lib/Makefile
@@ -17,6 +17,7 @@ obj-y += lmb.o
obj-y += longjmp.o
obj-$(CONFIG_CONSOLE_RECORD) += test_print.o
obj-$(CONFIG_SSCANF) += sscanf.o
+obj-$(CONFIG_$(XPL_)CMDLINE) += str.o
obj-y += string.o
obj-y += strlcat.o
obj-$(CONFIG_ERRNO_STR) += test_errno_str.o
diff --git a/test/str_ut.c b/test/lib/str.c
similarity index 100%
rename from test/str_ut.c
rename to test/lib/str.c
--
2.43.0
More information about the U-Boot
mailing list