[PATCH v2 22/30] xpl: Rename spl_phase to xpl_phase_t
Simon Glass
sjg at chromium.org
Sat Sep 28 22:00:22 CEST 2024
This name fits better with the new naming scheme, so update it.
Signed-off-by: Simon Glass <sjg at chromium.org>
---
(no changes since v1)
arch/sandbox/cpu/spl.c | 2 +-
common/spl/spl.c | 2 +-
doc/device-tree-bindings/bootph.yaml | 2 +-
include/spl.h | 12 ++++++------
4 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/arch/sandbox/cpu/spl.c b/arch/sandbox/cpu/spl.c
index 1c33a520c64..6c6f4fd8c3e 100644
--- a/arch/sandbox/cpu/spl.c
+++ b/arch/sandbox/cpu/spl.c
@@ -91,7 +91,7 @@ static int load_from_image(struct spl_image_info *spl_image,
struct spl_boot_device *bootdev)
{
struct sandbox_state *state = state_get_current();
- enum u_boot_phase next_phase;
+ enum xpl_phase_t next_phase;
const char *fname;
ulong pos, size;
int full_size;
diff --git a/common/spl/spl.c b/common/spl/spl.c
index 674ab35ede0..81b3501ebaf 100644
--- a/common/spl/spl.c
+++ b/common/spl/spl.c
@@ -441,7 +441,7 @@ static inline int write_spl_handoff(void) { return 0; }
*/
static enum bootstage_id get_bootstage_id(bool start)
{
- enum u_boot_phase phase = spl_phase();
+ enum xpl_phase_t phase = spl_phase();
if (IS_ENABLED(CONFIG_TPL_BUILD) && phase == PHASE_TPL)
return start ? BOOTSTAGE_ID_START_TPL : BOOTSTAGE_ID_END_TPL;
diff --git a/doc/device-tree-bindings/bootph.yaml b/doc/device-tree-bindings/bootph.yaml
index a3ccf06efa7..a364b3fe37f 100644
--- a/doc/device-tree-bindings/bootph.yaml
+++ b/doc/device-tree-bindings/bootph.yaml
@@ -83,6 +83,6 @@ properties:
bootph-all:
type: boolean
description:
- Include this node in all phases (for U-Boot see enum u_boot_phase).
+ Include this node in all phases (for U-Boot see enum xpl_phase_t).
additionalProperties: true
diff --git a/include/spl.h b/include/spl.h
index 01057ee103e..3447a429e87 100644
--- a/include/spl.h
+++ b/include/spl.h
@@ -62,7 +62,7 @@ static inline bool xpl_is_first_phase(void)
return false;
}
-enum u_boot_phase {
+enum xpl_phase_t {
PHASE_NONE, /* Invalid phase, signifying before U-Boot */
PHASE_TPL, /* Running in TPL */
PHASE_VPL, /* Running in VPL */
@@ -116,7 +116,7 @@ enum u_boot_phase {
*
* Return: U-Boot phase
*/
-static inline enum u_boot_phase spl_phase(void)
+static inline enum xpl_phase_t spl_phase(void)
{
#ifdef CONFIG_TPL_BUILD
return PHASE_TPL;
@@ -150,7 +150,7 @@ static inline bool spl_in_proper(void)
* Return: the previous phase from this one, e.g. if called in SPL this returns
* PHASE_TPL, if TPL is enabled
*/
-static inline enum u_boot_phase spl_prev_phase(void)
+static inline enum xpl_phase_t spl_prev_phase(void)
{
#ifdef CONFIG_TPL_BUILD
return PHASE_NONE;
@@ -172,7 +172,7 @@ static inline enum u_boot_phase spl_prev_phase(void)
* Return: the next phase from this one, e.g. if called in TPL this returns
* PHASE_SPL
*/
-static inline enum u_boot_phase spl_next_phase(void)
+static inline enum xpl_phase_t spl_next_phase(void)
{
#ifdef CONFIG_TPL_BUILD
return IS_ENABLED(CONFIG_VPL) ? PHASE_VPL : PHASE_SPL;
@@ -188,7 +188,7 @@ static inline enum u_boot_phase spl_next_phase(void)
*
* Return: phase name
*/
-static inline const char *spl_phase_name(enum u_boot_phase phase)
+static inline const char *spl_phase_name(enum xpl_phase_t phase)
{
switch (phase) {
case PHASE_TPL:
@@ -211,7 +211,7 @@ static inline const char *spl_phase_name(enum u_boot_phase phase)
* @phase: Phase to look up
* Return: phase prefix ("spl", "tpl", etc.)
*/
-static inline const char *spl_phase_prefix(enum u_boot_phase phase)
+static inline const char *spl_phase_prefix(enum xpl_phase_t phase)
{
switch (phase) {
case PHASE_TPL:
--
2.34.1
More information about the U-Boot
mailing list