[PATCH v3 08/29] treewide: Rename VENDOR_EFI to ARCH_EFI

Tom Rini trini at konsulko.com
Sun Feb 9 19:06:37 CET 2025


On Sat, Feb 08, 2025 at 07:01:07PM -0700, Simon Glass wrote:

> The 'vendor' concept comes from arch/x86. Rather than letting this
> spread around the tree, rename it to ARCH_EFI.
> 
> While EFI is not quite an architecture in the strict sense, it is
> similar to sandbox in that it sits somewhat above the CPU architecture.
> 
> Signed-off-by: Simon Glass <sjg at chromium.org>

Likely the best we can do for a generic enough name, thanks.

Reviewed-by: Tom Rini <trini at konsulko.com>

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20250209/db9652d8/attachment.sig>


More information about the U-Boot mailing list