[PATCH v3 12/29] efi: Rename ImageBase to image_base
Tom Rini
trini at konsulko.com
Mon Feb 10 16:52:11 CET 2025
On Sat, Feb 08, 2025 at 07:01:11PM -0700, Simon Glass wrote:
> It is confusing to have a camel-case indentifier in the these files.
> Rename them to fit with U-Boot's snake-case style.
>
> The image_base symbol is already used in the x86 link-scripts.
>
> Signed-off-by: Simon Glass <sjg at chromium.org>
> ---
>
> (no changes since v2)
>
> Changes in v2:
> - Rework the commit message to clarify the relationship to link-scripts
Thanks for explaining where this comes from a bit more. I still think
this is a case where our x86 code gets it backwards. To me following the
naming convention of the specification we're implementing is more
important than stylization. But I'd really like anyone else who deals
with this area to chime in.
--
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20250210/4f1ea803/attachment.sig>
More information about the U-Boot
mailing list