[PATCH 05/13] qconfig: Rename do_build_db()

Simon Glass sjg at chromium.org
Tue Jul 7 13:35:06 CEST 2026


This function does not actually build the database; it just adds a board
to the database. Rename it to do_add_to_db() to reflect that.

Signed-off-by: Simon Glass <sjg at chromium.org>
---

 tools/qconfig.py | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tools/qconfig.py b/tools/qconfig.py
index efdb0a0f472..c60cf5c4d1f 100755
--- a/tools/qconfig.py
+++ b/tools/qconfig.py
@@ -471,7 +471,7 @@ class Slot:
                 self.current_src_dir = None
                 self.do_defconfig()
             elif self.args.build_db:
-                self.do_build_db()
+                self.do_add_to_db()
             else:
                 self.do_savedefconfig()
         elif self.state == STATE_SAVEDEFCONFIG:
@@ -525,7 +525,7 @@ class Slot:
                                      cwd=self.current_src_dir)
         self.state = STATE_AUTOCONF
 
-    def do_build_db(self):
+    def do_add_to_db(self):
         """Add the board to the database"""
         configs = {}
         for line in read_file(os.path.join(self.build_dir, AUTO_CONF_PATH)):
-- 
2.43.0



More information about the U-Boot mailing list