[PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF

Tom Rini trini at konsulko.com
Wed Jul 8 00:48:42 CEST 2026


Now that we have made bloblist have distinct "find" and "create"
functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.

Suggested-by: Raymond Mao <raymondmaoca at gmail.com>
Signed-off-by: Tom Rini <trini at konsulko.com>
---
 common/bloblist.c                 | 8 ++++----
 include/asm-generic/global_data.h | 4 ++--
 include/bloblist.h                | 2 +-
 3 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/common/bloblist.c b/common/bloblist.c
index 51ae9cc50a5f..846c8047f746 100644
--- a/common/bloblist.c
+++ b/common/bloblist.c
@@ -448,7 +448,7 @@ int bloblist_new(ulong addr, uint size, uint flags, uint align_log2)
 	hdr->align_log2 = align_log2 ? align_log2 : BLOBLIST_BLOB_ALIGN_LOG2;
 	hdr->chksum = 0;
 	gd->bloblist = hdr;
-	gd->flags |= GD_FLG_BLOBLIST_READY;
+	gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
 
 	return 0;
 }
@@ -476,7 +476,7 @@ int bloblist_check(ulong addr, uint size)
 		return log_msg_ret("Bad checksum", -EIO);
 	}
 	gd->bloblist = hdr;
-	gd->flags |= GD_FLG_BLOBLIST_READY;
+	gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
 
 	return 0;
 }
@@ -627,7 +627,7 @@ int bloblist_init(void)
 	int ret;
 	ulong addr = 0, size = CONFIG_BLOBLIST_SIZE;
 
-	if (gd->flags & GD_FLG_BLOBLIST_READY) {
+	if (gd->flags & GD_FLG_BLOBLIST_HANDOFF) {
 		log_debug("Found existing bloblist size %x at %p\n",
 			  gd->bloblist->total_size, gd->bloblist);
 		return 0;
@@ -689,7 +689,7 @@ int bloblist_check_reg_conv(ulong rfdt, ulong rzero, ulong rsig, ulong xlist)
 	if (rfdt != (ulong)bloblist_find(BLOBLISTT_CONTROL_FDT, 0)) {
 		/* Remove this bloblist from gd */
 		gd->bloblist = NULL;
-		gd->flags &= ~GD_FLG_BLOBLIST_READY;
+		gd->flags &= ~GD_FLG_BLOBLIST_HANDOFF;
 		return -EIO;
 	}
 
diff --git a/include/asm-generic/global_data.h b/include/asm-generic/global_data.h
index ad7ebb1bbc95..fd116b0cebf2 100644
--- a/include/asm-generic/global_data.h
+++ b/include/asm-generic/global_data.h
@@ -697,9 +697,9 @@ enum gd_flags {
 	 */
 	GD_FLG_DM_DEAD = 0x400000,
 	/**
-	 * @GD_FLG_BLOBLIST_READY: bloblist is ready for use
+	 * @GD_FLG_BLOBLIST_HANDOFF: bloblist has been found.
 	 */
-	GD_FLG_BLOBLIST_READY = 0x800000,
+	GD_FLG_BLOBLIST_HANDOFF = 0x800000,
 	/**
 	 * @GD_FLG_HUSH_OLD_PARSER: Use hush old parser.
 	 */
diff --git a/include/bloblist.h b/include/bloblist.h
index 4c5787729654..fcd290eeb165 100644
--- a/include/bloblist.h
+++ b/include/bloblist.h
@@ -516,7 +516,7 @@ bool bloblist_exists(void);
  * If CONFIG_BLOBLIST_PASSAGE_MANDATORY is selected, bloblist in the incoming
  * standard passage is mandatorily required.
  *
- * Sets GD_FLG_BLOBLIST_READY in global_data flags on success
+ * Sets GD_FLG_BLOBLIST_HANDOFF in global_data flags on success
  *
  * Return: 0 if OK, -ve on error
  */
-- 
2.43.0



More information about the U-Boot mailing list