[PATCH v2 10/14] power: domain: mediatek: rename mtk_power_domain_probe to mtk_scpsys_probe

Julien Stephan jstephan at baylibre.com
Thu Jul 9 14:58:16 CEST 2026


Rename the flat, single-node probe to mtk_scpsys_probe so that the name
mtk_power_domain_probe can be reused for an upcoming nested
(power-controller) probe. Update the MT7623 and MT7629 drivers
accordingly.

No functional change intended.

Signed-off-by: Julien Stephan <jstephan at baylibre.com>
---
 drivers/power/domain/mt2701-power-domain.c | 2 +-
 drivers/power/domain/mt7622-power-domain.c | 2 +-
 drivers/power/domain/mtk-power-domain.c    | 2 +-
 drivers/power/domain/mtk-power-domain.h    | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/power/domain/mt2701-power-domain.c b/drivers/power/domain/mt2701-power-domain.c
index 58ef47c3001..a6297401f6a 100644
--- a/drivers/power/domain/mt2701-power-domain.c
+++ b/drivers/power/domain/mt2701-power-domain.c
@@ -83,7 +83,7 @@ U_BOOT_DRIVER(mt2701_power_domain) = {
 	.name = "mt2701_power_domain",
 	.id = UCLASS_POWER_DOMAIN,
 	.ops = &mtk_power_domain_ops,
-	.probe = mtk_power_domain_probe,
+	.probe = mtk_scpsys_probe,
 	.of_match = mt2701_power_domain_ids,
 	.priv_auto = sizeof(struct mtk_scp_domain),
 };
diff --git a/drivers/power/domain/mt7622-power-domain.c b/drivers/power/domain/mt7622-power-domain.c
index b98c384c3b1..339a896e19d 100644
--- a/drivers/power/domain/mt7622-power-domain.c
+++ b/drivers/power/domain/mt7622-power-domain.c
@@ -50,7 +50,7 @@ U_BOOT_DRIVER(mt7622_power_domain) = {
 	.name = "mt7622_power_domain",
 	.id = UCLASS_POWER_DOMAIN,
 	.ops = &mtk_power_domain_ops,
-	.probe = mtk_power_domain_probe,
+	.probe = mtk_scpsys_probe,
 	.of_match = mt7622_power_domain_ids,
 	.priv_auto = sizeof(struct mtk_scp_domain),
 };
diff --git a/drivers/power/domain/mtk-power-domain.c b/drivers/power/domain/mtk-power-domain.c
index 752ca404875..e0293aadfd8 100644
--- a/drivers/power/domain/mtk-power-domain.c
+++ b/drivers/power/domain/mtk-power-domain.c
@@ -158,7 +158,7 @@ static int mtk_scpsys_power_off(struct power_domain *power_domain)
 	return 0;
 }
 
-int mtk_power_domain_probe(struct udevice *dev)
+int mtk_scpsys_probe(struct udevice *dev)
 {
 	struct ofnode_phandle_args args;
 	struct mtk_scp_domain *scpd = dev_get_priv(dev);
diff --git a/drivers/power/domain/mtk-power-domain.h b/drivers/power/domain/mtk-power-domain.h
index ade77af8f33..830d6947962 100644
--- a/drivers/power/domain/mtk-power-domain.h
+++ b/drivers/power/domain/mtk-power-domain.h
@@ -86,7 +86,7 @@ struct mtk_scp_domain {
 	const struct mtk_scp_soc_data *soc_data;
 };
 
-int mtk_power_domain_probe(struct udevice *dev);
+int mtk_scpsys_probe(struct udevice *dev);
 
 extern const struct power_domain_ops mtk_power_domain_ops;
 

-- 
2.54.0



More information about the U-Boot mailing list