[U-Boot] [PATCH-ARM 1/4, v2] Clean-up of cpu_arm920t and cpu_arm920t_s3c24x0 code

kevin.morfitt at fearnside-systems.co.uk kevin.morfitt at fearnside-systems.co.uk
Fri Oct 2 23:25:50 CEST 2009



Minkyu Kang wrote:
> Dear kevin Morfitt
> 
> sorry for blank message
> 
> 2009/9/30 Minkyu Kang <promsoft at gmail.com>:
>> Dear Kevin Morfitt
>>
>> 2009/9/26 kevin.morfitt at fearnside-systems.co.uk
>> <kevin.morfitt at fearnside-systems.co.uk>:
>>> Changes since v1:
>>> - re-formatted patch to remove line wrapping
>>>
>>> Note that patch 2/4 of this series has not changed.
>>>
>>> This patch re-formats the code in cpu/arm920t and cpu/arm920t/23c24x0 in
>>> preparation for changes to add support for the Embest SBC2440-II Board.
>>>
>>> The changes are as follows:
>>> - re-indent the code using Lindent
>>> - make sure register layouts are defined using a C struct
>>> - replace the upper-case typedef'ed C struct names with lower case
>>>  non-typedef'ed ones
>>> - make sure registers are accessed using the proper accessor functions
>>> - run checkpatch.pl and fix any error reports
>>>
>>> Note that usb_ohci.c still has two lines that exceed 80 characters. This is
>>> because the statements on those lines lose readability when wrapped - the Linux
>>> coding style guidelines allow for this.
>>>
>>> It assumes the following patch has been applied first:
>>> - [U-Boot][PATCH-ARM] CONFIG_SYS_HZ fix for ARM902T S3C24X0 Boards, 05/09/2009
>>>
>>> Tested on an Embest SBC2440-II Board with local u-boot patches as I don't have
>>> any s3c2400 or s3c2410 boards but need this patch applying before I can submit
>>> patches for the SBC2440-II Board. Also, ran MAKEALL for all ARM9 targets and no
>>> new warnings or errors were found.
>>>
>>> Signed-off-by: Kevin Morfitt <kevin.morfitt at fearnside-systems.co.uk>
>>> ---
>>>  cpu/arm920t/s3c24x0/interrupts.c |    2 +-
>>>  cpu/arm920t/s3c24x0/speed.c      |   42 +-
>>>  cpu/arm920t/s3c24x0/timer.c      |   74 ++-
>>>  cpu/arm920t/s3c24x0/usb.c        |   30 +-
>>>  cpu/arm920t/s3c24x0/usb_ohci.c   | 1268 ++++++++++++++++++++------------------
>>>  cpu/arm920t/s3c24x0/usb_ohci.h   |  187 +++---
>>>  cpu/arm920t/start.S              |   63 +-
>>>  7 files changed, 873 insertions(+), 793 deletions(-)
>>>
> 
> I didn't see all of your patch.

Here are links to the patches and notes on their states:
- [U-boot] [PATCH-ARM] CONFIG_SYS_HZ change for cpu/arm920t/s3c24x0 boards:
  http://lists.denx.de/pipermail/u-boot/2009-September/thread.html, 
  JP said it looked OK but needed testing, then it was tested by Wolfgang
- [U-Boot] [PATCH-ARM 1/4, v2] Clean-up of cpu/arm920t and 
  cpu/arm920t/s3c24x0 code (this patch): one comment so far (your own)
- [U-Boot] [PATCH-ARM 2/4] Clean-up of s3c24x0 header files:
  http://lists.denx.de/pipermail/u-boot/2009-September/060111.html, 
  no comments as yet
- [U-Boot] [PATCH-ARM 3/4, v2] Clean-up of s3c24x0 drivers excluding nand 
  driver, http://lists.denx.de/pipermail/u-boot/2009-September/061583.html,
  one comment by Gaye Abdoulaye Walsimou, fixed in v2
- [U-Boot] [PATCH-ARM 4/4, v2] Clean-up of s3c24x0 nand driver,
  http://lists.denx.de/pipermail/u-boot/2009-September/061584.html,
  v1 was Acked by Scott here - 
  http://lists.denx.de/pipermail/u-boot/2009-September/060580.html

> But there are remained more works for cleaning

My aim is to clean up just the s3c24x0 common code so I can later add support 
for the Embest SBC2440-II Board. I can see that the rest of the arm920t code 
also needs cleaning but this would be a much bigger job and could be done 
later - I'd rather limit these patches to s3c24x0 code. 

> please use lower case name at C structure's members and functions

I think I have changed all structure names to lower case in the s3c24x0 code.
I also think I've changed all function names to lower case except where
the change would affect too many other areas - for example, if I change 
get_HCLK() to get_hclk() in cpu/arm920t/s3c24x0/speed.c I'd also need to 
change the same in include/common.h, cpu/lh7a40x, arm920t/imx and 
arm1176/s3c64xx and all functions that call get_HCLK() throughout u-boot. 
Again, this does need doing but could be done later.

Regards
Kevin

> 
> Thanks
> Minkyu Kang


More information about the U-Boot mailing list