[ELDK] ELDK 4.1 PPC/4xx Strip Exit Status on Errors

Grant Erickson gerickson at nuovations.com
Wed Sep 3 21:08:40 CEST 2008

This is more of an FYI for the next release of the ELDK than anything else
should this issue still exist in current versions of binutils.

Today I ran into an unexpected bit of behavior in 'ppc_4xx-strip' when
building a root file system and installation image for an embedded project.

Specifically, I saw the following error:

/usr/local/eldk/4.1/usr/bin/ppc_4xx-strip: unable to copy file
'~/src/results/root/usr/lib/libcrypto.so.0.9.8' reason: Permission denied

My tool checks for EXIT_SUCCESS/EXIT_FAILURE from the ppc_4xx-strip
executable and reacts accordingly; however, it turns out that the status was
EXIT_SUCCESS, despite this error, so the tool continued merrily along.

The root problem, of course, is that OpenSSL-0.9.8h installs its libraries
as 555:

-r-xr-xr-x 1 gerickson gerickson 1628911 2008-09-03 11:50

So, this is easily worked around by fixing how the OpenSSL package installs
its libraries; however, strip should return EXIT_FAILURE in this case.


Grant Erickson

More information about the eldk mailing list