[ELDK] gdbserver issues on xilinx PPC440 Virtex5FX with ELDK4.2

Frederic Leger Frederic.Leger at esisar.grenoble-inp.fr
Wed Feb 11 21:52:37 CET 2009


I am currently trying to get a gdbserver working on a xilinx PPC440
V5FX30T board.

I have experienced immediate good results on the PPC405 on xilinx V4FX12.

But this time I have some crazy issues with the PPC440.
The hardware design is fxt_evaluation_git_linux_edk10_1_2 from AVNET, we
our .dts file which is ok (almost the same as the avnet .dts file from the
xilinx git tree).

kernel is latest 2.6.28 from xilinx git.

I tried 2 days long ELDK 4.2 and its pre-built PPC440 gdbserver and host
Finally I also tried today the latest Buildroot 2009-02-rc4 that compiles
against the linux 2.6.28 includes.

We tested the gigabit TCP/IP link by crosscompiling netperf and have
excellent results.

It is possible to launch the gdbserver on the target and connect from the
host using the host ELDK gdb,Buildroot gdb,  or ddd, or insight-eabi from
(Because ELDK doesn't tag "PPC440" the executable produced, but "generic
powerpc" I have to set the processor option in the gdb settings file for
the gdb-insight-eabi of xilinx EDK otherwise the tool chooses a PPC405.)

I can set breakpoints on the C code of an helloworld app (statically
linked or not, uclibc(Buildroot) or glibc(ELDK)).

#include <stdio.h>
int main(int argc, char **argv)
  printf("helloworld 1\n");
  printf("helloworld 2\n");
  printf("helloworld 3\n");
  return 0;

It is possible to read the registers of the PPC440...the target is
responding to host gdb commands.

Problem is: gdbserver crashes when gdb (HOST) is trying to run or continue
with breakpoints.

 programs are compiled using:

ELDK(PPC_4XX):  powerpc-linux-gcc helloworld.c -o helloword -mcpu=440
-msoft-float -g

BUILDROOT(PPC_440/soft-floats):  powerpc-linux-gcc helloworld.c -o
helloword -g

All apps work fine without being debugged (ie: helloworld, netperf).

Only one time, surprizingly, I got a full run and normal exit (no
breakpoints) under gdbserver.

By the past, I never experienced this kind of problem on V4FX and PPC405
using Buildroot.

Can you please tell me a way to sort that out ? any idea, procedure,
example, would be very helpfull !!!

Thank you in advance.


More information about the eldk mailing list