[ELDK] gdbserver issues on xilinx PPC440 Virtex5FX with ELDK4.2

Frederic LEGER frederic.leger at esisar.grenoble-inp.fr
Tue Feb 24 09:11:38 CET 2009

Dear Wolfgang,

Just to tell you that I used ELDK4.1-UCLIBC with 2.6.27-rc9 with same crazy

I also used latest stable Buildroot 2009.02 with GCC4.3.2, latest uclibc
etc... Etc... With kernel 2.6.28 from xilinx git tree : same result, GDB on
the target is crashing after setting a break point and "continue".

The problem exists with the GDB on the target, and by extension with

I also compiled a kernel using SLUB allocator, with same results. 

Replies on Xilinx forum tells me that I am no more the only one to have this
issue. (copy of a post below)

Regular Visitor
Posts: 18
Registered: 03-17-2008 

Message 2 of 2
Viewed 20 times
 I have duplicated this problem on the Avnet V5FX30T board with the ELDK 4.2
toolchain and 2.6.27rc4, 2.6.27rc9 and 2.6.28 kernels.

I have also duplicated this problem on the Xilinx ML507 board with the ELDK
4.2 toolchain and 2.6.27rc9 kernel.
Telling gdb to "continue"  hangs the debug session and, of course, the
breakpoint is never hit. 

I configure the kernel to mount the ELDK root file system over NFS.  The
kernel boots and runs with no issues.
Here are the rest of my steps:
Compile my application and copy the exe to the NFS share:
$ ppc_4xx-gcc -Wall -ggdb -o hello_world hello_world.c $ cp hello_world
Start gdbserver on the target:
-bash-3.2# gdbserver /bin/hello_world (I see the expected
"process created" and "Listening on port 1234" messages in the console)
Start gdb on the host:
ppc_4xx-gdb hello_world
(I see the typical and expected startup messages.  One interesting thing
here - gdb says the target architecture is set automatically to powerpc:403.
Attempts to set the target arch with "set processor powerpc:440" fail with
an "Undefined item: "powerpc:440"" message.) 

Set breakpoint, connect to target, and attempt to hit the breakpoint:
(gdb) break 5 (the printf statement is on line 5)
(gdb) target remote
(gdb) continue

At this point the debug session hangs and the board goes out to lunch.  I
can halt the debug session and get gdb back with a <ctrl-c> <ctrl-c>, but
the board does not recover.  I have to re-download the kernel elfto
essentially reset the board.

Most interesting of all is that I know - and have documented - this exact
process for debugging applications in this same environment.  Something
obviously has gone very wrong.  Anyone have any ideas?  Suggestions?

Best regards,

Frédéric LEGER
Transfert de Technologie
Grenoble-INP Esisar
50 rue Barthélémy de Laffemas
BP54 - 26902 Valence Cedex 9
Tel: +33(0)475759475
Fax: +33(0)475435642
web: http://www.esisar.grenoble-inp.fr 


-----Message d'origine-----
De : Wolfgang Denk [mailto:wd at denx.de] 
Envoyé : lundi 23 février 2009 21:38
À : Frederic LEGER
Cc : eldk at lists.denx.de
Objet : Re: [ELDK] gdbserver issues on xilinx PPC440 Virtex5FX with ELDK4.2

Dear Frederic,

In message <001b01c991d8$441fada0$3e0414ac at esisar.inpg.fr> you wrote:
> Since my last message I tried several things, without real success...

Did you - just for comparison - happen to try the same with the tools from
ELDK 4.1 ?

Best regards,

Wolfgang Denk

DENX Software Engineering GmbH,     MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"You're just jealous." "What, of an overgrown puppy  with  a  single-
figure IQ?"                      - Terry Pratchett, _Moving Pictures_

More information about the eldk mailing list