[ELDK] Rebuilding ELDK-4.1-uclibc with IPv6 support

J.T. Conklin jt.conklin at xorp.net
Wed Feb 25 03:08:45 CET 2009

On Tue, Feb 24, 2009 at 9:22 AM, J.T. Conklin <jt.conklin at xorp.net> wrote:
>> What exactly were the commands you used to do this? Did you follow
>> the instructions in the manual to the letter?
>> Did you - for example - export UCLIBC=1 ?

Hi again,

I thought that I might have better luck if I tried rebuilding the
whole ELDK from scratch as described on the "Rebuilding ELDK From
Scratch" wiki page

I was able to fetch the "build" and "tarballs" directories with:

    git-clone git://www.denx.de/git/eldk/build
    git-clone git://www.denx.de/git/eldk/tarballs

And I cut over to the ELDK-4.1 branch with:

    git-checkout ELDK_4_1

In each workspace.

I created an empty SRPMS directory, and set $ELDK_PREFIX to point to
the directory containing build and tarballs.

ELDK_BUILD failed downloading the SRPMS.  I discovered that Red
Hat/Fedora Project has changed the location, and with the following
change to the ELDK_BUILD script, I was able to download most of them:

@@ -19,8 +19,8 @@ done
 : ${BUILD_DIR:=${ELDK_PREFIX}/build}
 : ${TARBALL_DIR:=${ELDK_PREFIX}/tarballs}
-: ${SRPMS_URL:='ftp://download.fedora.redhat.com/pub/fedora/linux/core/4/SRPMS'
-: ${SRPMS_UPDATES_URL:='ftp://download.fedora.redhat.com/pub/fedora/linux/core/
+: ${SRPMS_URL:='http://archives.fedoraproject.org/pub/archive/fedora/linux/core
+: ${SRPMS_UPDATES_URL:='http://archives.fedoraproject.org/pub/archive/fedora/li
 : ${CROSS_ARCH:="ppc"}
 : ${ELDK_VERSION:="4.1"}
 : ${BUILD_NAME:=`date "+%Y-%m-%d"`}
@@ -50,8 +50,8 @@ function download_srpm() {

        echo "## Downloading Source RPM $rpm"
        rm -f ${rpm}
-       ncftpget -v ${SRPMS_URL}/${rpm} || \
-       ncftpget -v ${SRPMS_UPDATES_URL}/${rpm}
+       wget ${SRPMS_URL}/${rpm} || \
+       wget ${SRPMS_UPDATES_URL}/${rpm}

        cd $old

Unfortunately, the following SRPMS were not found:


Do you know of a place where these are still archived/available? I
haven't had much luck so far.

I even tried checking out the SRPM git repository, but it doesn't seem
to have a ELDK_4_1 tag/branch.

Many thanks for any additional help you may be able to offer.


More information about the eldk mailing list