[ELDK] undefined reference to 'Abort'

Shadid, Bill wshadid at neptec.com
Thu Feb 17 17:37:21 CET 2011

Hi Folks,


We were using ELDK 4.1 for the powerpc for a few now with no problems.


We then needed to use some new library tools and were forced to move to
4.2 (another s/w eng could elaborate).

The move went smoothly except for my test s/w. It compiles as a
sub-directory of u-boot (ver 1.2.0).

We were getting the error "undefined reference to 'Abort'" along with
some other messages about divdf3, divsf3, muldf3 calling the Abort

Some blog indicated that we could make our own abort function and it
would just have "int I =0;" in it. Well this satisfied the compiler but
executing the code did not go well. The system continually spit out that
annoying crash message with register dumps. I also tried just a printf
and that did not crash the system but it just terminated my program and
returned control to u-boot. 


I have not supplied any dumps, I could, but I was hoping someone would
have already seen the fault, fixed it and have a solution in their back
pockets. If that's not the case, I could gather up dumps and add them to
the email.


When the test s/w was compiled successfully on the older eldk, I would
just jump to the start of the program + 4, i.e. go fff20004.


Thanks in advance for your assistance,

William Shadid

Software Development Specialist



More information about the eldk mailing list