AW: [U-Boot-Users] F.A.O Rune Torgersen or any MPC8266ADS-PCI u-boot users

Georg Klug gklug at
Tue Aug 5 20:36:06 CEST 2003

Hi all,

yes, we got this board to work. But in order to help you we would need to
know exactly what happened in your case. What do you mean by "It doesn' work?"

First you should know is that you should care about the jumper setting as Rune
explained in one of his latest e-mails (see archive)
Second: we had a problem with the SDRAM setting. Either diabling the PBI or
fixing line the sdam setting of the SDRAM helped.
Third: please always work with the newest u-boot from the CVS for such


>         I am a newbie to u-boot and I am trying to get u-boot0.4.0 to
> download to the flash on an MPC8266ADS-PCI development board.  I managed to
> get u-boot0.2 on the flash and working as it should but unfortunately it
> needed fixed for the PCI features of the 8266. I have tried 0.3 and 0.4 but
> cannot get it to work.  Both myself and some guys at Motorola have been
> trying for 4-6 weeks now to get u-boot & PCI up and running.  Has anyone
> managed to get u-boot to work on this platform with PCI support enabled? If
> so, I would be greatful if could you mail the .srec to cd7 at
>         First of all I am using ELDK to cross compile the u-boot source
> which seems to work fine.  The problem is that it doesn't seem to like the
> Flash very much.  I am using the Sharp type flash.  I have tried the both
> the default configurations, with no success and also modified the following
> settings, also without much success.
> 1.)    Within {u-boot}/include/configs/MPC8266ADS.h there are two choices
> for CFG_HRCW_MASTER depending on which JP setting you want to use - does
> anyone know which one is best to choose here?

> 2.)    Also the settings for the CFG_FLASH_BASE default to 0xFE000000.  From
> the MPC8266 user manual I noticed that the memory location this relates to
> is for a 32M SIMM whereas I have 8M which starts at FF800000.  I changed
> this to mirror the user manual and update also the CFG_BR0_PRELIM
> accordingly (0xFF801801).
> 3.)    I have also played around with the
> {u-boot_dir}/board/mpc8266ads/ file to no avail.
> If someone out there has managed to get this working it would be great if
> you could either explain everything I need to do to get it blown to the
> flash on this type of board. Like I say I am a newbie to this and probably
> need to plead ignorance, or
> b) have a working copy for an MPC8266ADS-PCI that you could send to me as I
> can't proceed past this point.
> Any help is very much appreciated.  Thanks
> Ciaran Doyle
> _________________________________________________________________
> Tired of spam? Get advanced junk mail protection with MSN 8.
> -------------------------------------------------------
> This SF.Net email sponsored by: Free pre-built ASP.NET sites including
> Data Reports, E-commerce, Portals, and Forums are available now.
> Download today and enter to win an XBOX or Visual Studio .NET.
> _______________________________________________
> U-Boot-Users mailing list
> U-Boot-Users at

More information about the U-Boot mailing list