[U-Boot-Users] MPC860T POST

Wolfgang Denk wd at denx.de
Mon Jun 23 09:25:27 CEST 2003

In message <sef6ed4e.055 at gw_tus_syd3.tus.au.thales> you wrote:
> I'm working with an MPC860T on a custom designed board, using
> ppcboot-2.0.0.  I've only recently tried to turn on the POSTs that is

PPCBoot is dead. Please use U-Boot instead.

> offered with ppcboot/uboot and have tried to 
> 			CFG_POST_MEMORY    	| \
>  			CFG_POST_CPU 		| \
> 			CFG_POST_CACHE		| \
> 			CFG_POST_UART		| \
> 			)
> However, on compilation, I get the following:
> {standard input}: Assembler messages:
> {standard input}:513: Error: Relocation cannot be done when using
> -mrelocatable
> {standard input}:519: Error: Relocation cannot be done when using
> -mrelocatable
> {standard input}:525: Error: Relocation cannot be done when using
> -mrelocatable

You have omitted the interesting part: the command line  causing  the
error.  It  seems  to  me  you are not using the correct command line

> Any ideas?  should I be able to compile this with version 3.0.4?  If
> so, how can I get this to work?

Version 3.0.4 of what?

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de
Another Armenia, Belgium ... the weak innocents who always seem to be
located on a natural invasion route.
	-- Kirk, "Errand of Mercy", stardate 3198.4

More information about the U-Boot mailing list