[U-Boot-Users] U-boot for 8245 boards

Karoliya, Abhishek Abhishek.Karoliya at fci.com
Sat May 17 09:14:28 CEST 2003

 Thanks Chris for the message 
but that isnt the case really. On startup ,typing INFO does give "COP freeze
(startup)" but on typing ti gives "trace" and typing go gives "TARGET :
entered Debug state " and than typing info 
Debug entry cause gives <reserved 0>.


-----Original Message-----
From: Chris Hallinan [mailto:clh at net1plus.com]
Sent: Saturday, 17 May 2003 12:58 AM
To: Karoliya, Abhishek; u-boot-users at lists.sourceforge.net
Cc: u-boot-users at lists.sourceforge.net
Subject: RE: [U-Boot-Users] U-boot for 8245 boards

Abhishek Karoliya wrote:
>      I am trying to port U-boot to a customised 8245 board .
> For the Initial bring up , I am using a working U-Boot
> for another very
> similar board. The problem is that, using
> BDI 2000 debugger , The telnet Interface reports it to be
> at reset address
> fff0 0100 all the time and no amount of ti or go works
> When I use gdb it also reports it to be stuck there and a
> step command
> results in gdb reporting that a stop signal received .
> I tried setting break points ahead but no use.
> The BDI set-up is working as i tried it with working
> image of vxWorks loader
> bootrom.

This does not necessarily indicate your setup is correct, which it
likely isn't.  When you do an 'info' command from Telnet, after
typing 'ti' or 'go', do you see "Debug entry cause " COP freeze
(startup)?  This generally indicates that the 8245 has entered check
stop state due to a hardware/configuration/setup/procesor
initialization issue.  You will have to debug it.


Chris Hallinan
DS4.COM, Inc

More information about the U-Boot mailing list