[U-Boot-Users] U-boot for 8245 boards

Chris Hallinan clh at net1plus.com
Fri May 16 21:28:14 CEST 2003

Abhishek Karoliya wrote:
>      I am trying to port U-boot to a customised 8245 board .
> For the Initial bring up , I am using a working U-Boot
> for another very
> similar board. The problem is that, using
> BDI 2000 debugger , The telnet Interface reports it to be
> at reset address
> fff0 0100 all the time and no amount of ti or go works
> When I use gdb it also reports it to be stuck there and a
> step command
> results in gdb reporting that a stop signal received .
> I tried setting break points ahead but no use.
> The BDI set-up is working as i tried it with working
> image of vxWorks loader
> bootrom.

This does not necessarily indicate your setup is correct, which it
likely isn't.  When you do an 'info' command from Telnet, after
typing 'ti' or 'go', do you see "Debug entry cause " COP freeze
(startup)?  This generally indicates that the 8245 has entered check
stop state due to a hardware/configuration/setup/procesor
initialization issue.  You will have to debug it.


Chris Hallinan
DS4.COM, Inc

More information about the U-Boot mailing list