[U-Boot-Users] Re: IBM 440GX eval name

Jarrett Redd coin068_redd at yahoo.com
Wed Apr 7 20:17:05 CEST 2004

--- Travis Sawyer <tsawyer+u-boot at sandburst.com>
> I don't have another DIMM handy, so I couldn't
> test that.

Ok, just out of curiousity, I found another DIMM to
try and test, but with 2 it hangs at the "DRAM:  "

> > In addition, I can't seem to bring up the
> > network.  
> See below...
> > ethaddr=<macaddr>
> There's your problem. Do the following:
> setenv ethaddr XX:XX:XX:XX:XX:XX
> setenv eth1addr YY:YY:YY:YY:YY:YY
> setenv eth2addr ZZ:ZZ:ZZ:ZZ:ZZ:ZZ
> setenv eth3addr AA:AA:AA:AA:AA:AA

Well, the '<macaddr>' in the above output was edited
by me for the email purposes.  Sorry about that.  I
have the actual mac addr in there but was masking it
out since this list is archived on the internet. 
Similarly for the other masked settings.

An interesting thing to note here is, the 'ethaddr'
value was automatically set somehow (is there auto
detection support here?), but it was incorrect in the
final byte, at least compared to any of the 4
stickers.  I rebooted under PIBS and unfortunately got
4 more different mac addresses that also do not match
the stickers in the last 2 bytes.  So, they all seem
to be valid IBM mac values for this board, but I'm not
really certain which mac addresses are really mine for
this board.  So anyway I just entered the ones on the

> > => ping <address>
> > Waiting for PHY auto negotiation to complete..
> > done
> > ENET Speed is 100 Mbps - FULL duplex connection
> > ping failed; host <address> is not alive
> > 
> Hmmm...  since your setup is using EMAC0, ensure
> you have the cable in port 0.  Also, the only enet
> group supported is group 4, so ensure you have the
> jumpers set that way. (J79, J80, J29, J31, J76,
> J81) are all 1-8 and 3-6.

Yes, I checked and they are correct.  Still no joy. 
Other ideas?  The network comes up just fine under
PIBS with the same settings.  Also, is loopback
supported?  I cannot ping loopback or the board's own
ip address either.  In addition, every time I try to
ping, it always waits for auto negotiation.  That
doesn't seem normal.

Another thing I noticed that doesn't seem normal is
that the board seems to hang on the 'reset' command or
after using the reset button on the board.

Incidentally, just for fun, I tried burning the image
into the 4MB alternate flash and booting from that. 
It works just fine, other than flash detection getting
a bit confused.  :-)


Do you Yahoo!?
Yahoo! Small Business $15K Web Design Giveaway 

More information about the U-Boot mailing list