[U-Boot-Users] [PATCH] Cleanup cpu/arm920t

llandre r&d2 at dave-tech.it
Mon Aug 9 12:50:44 CEST 2004

> >    - rename cpu/arm920t/usb_ohci.c to drivers/s3c24x0_usb_ohci.c
>I disagree with  this.  drivers/  is  for  device  drivers  that  are
>_common_  among  architectures.  It makes absolutely no sense to mode
>processor  specific  code  like  the  s3c24x0  USB  drivers  to  this
>Please move this into cpu/arm920t/s3c24x0/ instead.

1) What about the Makefile in cpu/arm920t? Is it sufficient to change OBJS 
like this?

OBJS    = cpu.o \
           imx_generic.o imx_interrupts.o imx_speed.o \
           interrupts.o \
           s3c24x0_interrupts.o s3c24x0_serial.o s3c24x0_speed.o \
           usb_ohci.o \
           ep93xx/ep93xx_interrupts.o \
           ep93xx/ep93xx_net.o \
           ep93xx/ep93xx_serial.o \

2) Should the new processor-specific files keep the header (ep93xx_ in the 
previous example) in the name?
As a new directory has been introduced, it is clearly redundant.



DAVE Electronics System House - R&D Department
web:   http://www.dave-tech.it
email: r&d2 at dave-tech.it

More information about the U-Boot mailing list