[U-Boot-Users] Re: [PATCH] - fixed missing System ACE CF device

Stephen Williams steve at icarus.com
Tue Aug 10 23:58:57 CEST 2004

Hash: SHA1

Sean Chang wrote:
| Hi,
| If there are any problems please let me know and I'll be more than happy
| to fix it.  This patch is applied against the u-boot 1.1.1 release.  The
| CHANGELOG is below.
| Regards,
| Sean
| =======================================================================
| CHANGELOG (ace_fat.patch):
| Patch by Sean Chang, 9 Aug 2004:
|         Fixed missing System ACE CF device during get FAT partition info
| in fat_register_device function.
| =======================================================================

I did a few basic tests. This simply does not work. All I get is:

~ => fatls ace 0
~ ** Partition 1 not valid on device 0 **

~ ** Unable to use ace 0:1 for fatls **

get_partition_info simply doesn't work on any CompactFlash cards
that I tried. Have you seen any different? I tried a disk that was
"formatted at the factory" and disks that I partitioned via fdisk.
Even though Linux has no trouble with any of these, and fatls
works without your patch, get_partition_info doesn't work.

- --
Steve Williams                "The woods are lovely, dark and deep.
steve at icarus.com           But I have promises to keep,
http://www.icarus.com         and lines to code before I sleep,
http://www.picturel.com       And lines to code before I sleep."
Version: GnuPG v1.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the U-Boot mailing list