[U-Boot-Users] Re: [PATCH] - fixed missing System ACE CF device

Sean Chang sean.chang at xilinx.com
Wed Aug 11 03:11:40 CEST 2004

Hi Stephen,

> I did a few basic tests. This simply does not work. All I get is:
> ~ => fatls ace 0
> ~ ** Partition 1 not valid on device 0 **
> ~ ** Unable to use ace 0:1 for fatls **
> get_partition_info simply doesn't work on any CompactFlash cards
> that I tried. Have you seen any different? I tried a disk that was
> "formatted at the factory" and disks that I partitioned via fdisk.
> Even though Linux has no trouble with any of these, and fatls
> works without your patch, get_partition_info doesn't work.

hum, without the patch nothing works for me.  I was able to use the fat
commands fine with the CompactFlash card that I tried.  Perhaps you
could forward me a copy of the disk image for the CompactFlash card that
fails.  Also, can you tell me what type of CompactFlash card you have
(e.g. size) and what is your board environment (e.g. processor).  Just
trying to gather more information to figure out what is going wrong.

Thank you for your feedback and testing.


More information about the U-Boot mailing list