[U-Boot-Users] LITE5200 board: Bus Fault with 2 network cards

Olivier Singla olivier at singla.us
Tue Jul 13 04:12:01 CEST 2004


I use a Lite5200 board (ref. board from Motorola). With the two PCI network
cards I tried (which I would want to use under Linux 2.4.25), u-boot 

U-Boot 1.1.2 (Jul 12 2004 - 20:10:35)

CPU:   MPC5200 v1.2 at 396 MHz
     Bus 132 MHz, IPB 132 MHz, PCI 33 MHz
Board: Motorola MPC5200 (IceCube)
I2C:   85 kHz, ready
DRAM:  64 MB
PCI:   Bus Dev VenId DevId Class Int
Bus Fault @ 0x03fac1e8, fixup 0x00000000
Machine check in kernel mode.
Caused by (from msr): regs 03f5ad68 Unknown values in msr
NIP: 03FAC1E8 XER: 00000000 LR: 03FAC1DC REGS: 03f5ad68 TRAP: 0200 DAR: 
MSR: 00003000 EE: 0 PR: 0 FP: 1 ME: 1 IR/DR: 00

GPR00: 03FAC1DC 03F5AE58 00000000 FFFFFFFF FFFFFFFF 00000000 00000000 
GPR08: 03F8FA50 50AEF503 03FCB950 00000000 44004004 00000000 03FBA000 
GPR16: 00000000 00000000 00000000 00000000 00000000 00000001 00000000 
GPR24: 00000000 00000001 00000000 03F5AE88 F0000DF8 03F5AF84 03F5AEA8 
Call backtrace:
machine check

(I tried 1.1.1 first and then gave a try to the cvs version).

One network card I tried is the SMC9452TX (Marvell chip).

Two others PCI cards, not network (Maxtor SATA and USB-2.0) did not bring
any issue with u-boot 1.1.1

Is there a known issue with the PCI on the MPC5200, and more specifically
with PCI network cards ?
Or is-that with the u-boot PCI implementation for this board ?

I tried to disable the PCI from the u-boot/IceCube config file,
but then u-boot hangs up...

Any suggestion ?

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20040712/fe53476a/attachment.htm 

More information about the U-Boot mailing list