[U-Boot-Users] CFG_FLASH_BASE and CFG_MONITOR_BASE question

Wolfgang Denk wd at denx.de
Thu Jul 15 00:41:26 CEST 2004

In message <BAY2-F42kIFqFtucwpX000d8fad at hotmail.com> you wrote:
> Yes, I did try it out. Seems the u-boot works fine and the example 
> application runs fine in SDRAM. But when I tried to load the kernel, kernel 
> hangs when early_init (in head_4xx.S) is called. So I want to come back to 
> u-boot and double check everything in u-boot is correct.

I think we've been there before. How do  you  know  that  the  kernel
"hangs", and what exactly means "hangs" here?

Don't tell me again that you added some debug code to toggle LED's or
write to memory or something like that.

Your "it hangs" may be an "it chrashes because of  your  debug  code"
with your debug code, and something completely different without it.

Attach a debugger and find out what's really going on.

In a first step, I recommend to re-read the FAQ section.

> BTW, does anyone happen to have early_init problem and solved it? I saw a 

Yes. Many people have posted such problems before, and in all cases I
can remember the only problem was  some  debug  code  that  had  been
added,  or  the attempt to use tools (or engineers) that have no idea
what virtual memory is.

> lot of discussions on the internet. But most of them didn't give a final 
> solution. It doesn't matter if we are using same board or CPU. I just want 
> to get some idea of what could be wrong. Any input would be appreciated!

We've been there before. Everything has been said before. follow  the
advice,  or  ignore  it  -  your  choice. I give up here. I will stop
reading this thread and replying to it.

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de
What about WRITING it first and rationalizing it afterwords?  :-)
                       - Larry Wall in <8162 at jpl-devvax.JPL.NASA.GOV>

More information about the U-Boot mailing list