[U-Boot-Users] PPC 8260 Linux boot

Wolfgang Denk wd at denx.de
Mon Jul 26 19:02:16 CEST 2004

In message <4105294D.5070508 at helicontech.co.il> you wrote:
> I am trying to boot Linux 2.4.25 (code from denx linux-2-4-devel)
> The board is similar to MPC8260ADS

Arghh...  A  description  like  this  is  absolutley   useless,   and
misleading.  Your probably even fooling yourself. Similar? In that it
uses the same processor? Or is everything IDENTICAL?

> What happens is that the kernel is starting but after a short while gets 
> an exception and the board is reset again.

Please define "after a short while". Do you see any boot messages  on
the  console?  Do you see any messages when you do a post mortem dump
of the log_buf memory?
[See http://www.denx.de/twiki/bin/view/DULG/LinuxPostMortemAnalysis]

> We tried looking at the kernel sources to see where we get, we did this 
> by lighting hardware LEDS we have on the board.

I see. Please remove ALL this code and try again. perhaps it is  just
your  debugging  code  which  crashes  the  system.  [This  has  been
discussed before, both here and in the linuxppc mailing lists. Search
the archives.]

> We tried to find where in the kernel we get the exception, we could not 
> find exactly where it happens, but we did find that it happens somewhere 
> in the function prom_init called from early_init inside 
> arch/ppc/kernel/setup.c
> Does anyone have any idea what we should look next?

OK, I'll give you two hints:

1) get yourself a BDI2000. You will need it.

2) Check your memory map, and the init sequence of  your  SDRAM  [no,
   I'm not going to explain this here again. Search the archives.]

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: wd at denx.de
And now remains  That we find out the cause of this effect, Or rather
say, the cause of this defect...           -- Hamlet, Act II, Scene 2

More information about the U-Boot mailing list