[U-Boot-Users] uboot on an ipengine

Charles Lockhart lockhart at IfA.Hawaii.Edu
Thu Dec 15 02:29:18 CET 2005

I'm trying to get u-boot to run on an ipengine (mpc823 based device).  BSE (company that makes the ipengine) told me to use the binary generated from the RPXLite configuration.  I tried this, it didn't work, but I think I'm doing it wrong.

I'm building everything with the ELDK.  I was able to successfully build a zImage Linux kernel image (ELF), and I can get that to run by placing it at memory location 0x200000 and then telling the ipengine internal boot loader to jump to 0x210000.  This bypasses the ELF header and jumps into the code, and it works great.  I was thinking that maybe I have to do something like that for the u-boot image (also an ELF), but it didn't work.

I was also successful using "ppc_8xx-objcopy -O binary zImage zImage.bin" to create a kernel image that booted directly (I place it at 0x200000 and have the internal bootloader jump directly to 0x200000), but when I tried this with the RPXLite u-boot image, it also didn't work.

ELDK version is 3.1.1 (build 2005-06-07). U-boot version is off the cvs source tree from last week.  The kernel that I built successfully was the linuxppc 2.4 also off the cvs source tree from last week.

The other time I used u-boot (for an ml300 board) it came up pretty easily.  This time I'm just not seeing something, but haven't figured out what yet.

Thanks for your time,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.denx.de/pipermail/u-boot/attachments/20051214/ea4ce6b3/attachment.htm 

More information about the U-Boot mailing list