[U-Boot-Users] Booting problems for Integrator/CP+ARM920T

Alan Casey alan.casey5 at mail.dcu.ie
Fri Feb 4 16:04:27 CET 2005

 I am still having trouble booting Linux on the ARM
 Integrator/CP with an ARM920T macrocell. I have tried
 Peter Pearse's Patches which enable U-Boot to support
 the ARM920T macrocell but i can get message as before:

>>     Starting Kernel ...
>>   Then nothing - the boot process freezes.

>I have the feeling that you might have missed to read the FAQ, especially

 I have checked the above note but this is already the default with
 Linux-2.6.9 (i.e. i dont have to modify anything here for ARM).

 I am trying to boot the kernel(+ramdisk) from RAM so when 
 building the kernel i use the following setting:

CONFIG_CMDLINE="console=ttyUA0 mem=128M root=/dev/ram0 video=vc:1-2clcdfb
ramdisk_size=17408 initrd=0x24500000,6980391

 And in U-Boot i set:
 setenv bootargs console=ttyUA0 mem=128M root=/dev/ram0 video=vc:1-2clcdfb

 Is this correct? Even if i just try to boot the kernel ignoring the
 RAMDisk i still get "Starting kernel ..." then freeze nothing happens.

 Any info appreciated,



More information about the U-Boot mailing list