[U-Boot-Users] 2.6.12 with u-boot-1.1.2 on versatile

Wolfgang Denk wd at denx.de
Thu Jul 14 18:48:49 CEST 2005

In message <20050714152729.93962.qmail at web30709.mail.mud.yahoo.com> you wrote:
> > <U-Boot dir>/tools/mkimage -A arm -O linux -T kernel
> > -C none -a 0x7fc0
> > -e 0x8000 -n u-linux -d <Kernel dir>/arch/arm/Image
> > u-linux
> Worked like a charm!
> I then had to copy the kernel to SDRAM 0x7fc0 and boot
> it using:
>   cp 0x36000000 0x7fc0 <kernel_size>
>   bootm 0x7fc0

This is totally broken. You don't have to copy the  kernel  anywhere,
this is done automatically by the bootm command.

> I then tried to use the base.cramfs filesystem
> provided in arm.com:
>   bootm 0x7fc0 0x04000000

A cramfs filesystem on a MTD device is NOT an initial  ramdisk  which
you  claim  it  is  when  using  bootm  with  thwo arguments. This is
supposed to fail.

Best regards,

Wolfgang Denk

Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
Don't tell me how hard you work.  Tell me how much you get done.
- James J. Ling

More information about the U-Boot mailing list