[U-Boot-Users] Stuck relocating command table

Gregg Nemas gnemas at gmail.com
Fri Jul 22 08:10:26 CEST 2005

I have been trying unsuccessfully to bring up u-boot on my PowerPC 440GP
evaluation board. I am using the predefined configuration file for this board
(EBONY.h). I have tried both the 1.1.2 release and the head CVS files, both with
the same result.

It displays the expected initial messages and then hangs after displaying the
DRAM amount. I traced the code to find out where it is hanging. It makes it to
board_init_r in board.c, and enters the loop in which u-boot is relocating the
command table. It never gets out of this loop.

One peculiar thing is that when I printed out the value of __u_boot_cmd_start
and __u_boot_cmd_end just before the loop, they did not match what the
u-boot.map file says they should be.

The printed versions were

__u_boot_cmd_start = 0x07faeed8
__u_boot_cmd_end = 0x07ff57f4

(difference 0x4691C)

The u-boot.map versions are

__u_boot_cmd_start = 0xfffa57f4
__u_boot_cmd_end = 0xfffa8ffc

(difference 0x3808)

The loop seems to be reading from the wrong flash locations because it is
reading garbage.

Can someone help me figure this out? Could it be the build tools? I am using gcc
3.3.6 and binutils 2.16.1. Are these okay for building u-boot?



More information about the U-Boot mailing list