[U-Boot-Users] Strange memory allocation problem in linux

Yu JunMiao-r61929 j.m.yu at freescale.com
Thu Mar 24 04:24:05 CET 2005

I just met this problem also, with the correct uclinux image, and correct entry point in the SDRAM, and then "go" as an application,
But the uclinux can not boot....I am now searching the web and wish can get some tip...

-----Original Message-----
From: u-boot-users-admin at lists.sourceforge.net [mailto:u-boot-users-admin at lists.sourceforge.net] On Behalf Of Ara Avanesyan
Sent: 2005年3月23日 17:17
To: u-boot-users at lists.sourceforge.net
Subject: [U-Boot-Users] Strange memory allocation problem in linux


I do not know whether this is a right group to ask this question, but i'm giving it a try. Here is what I have, I have a loadable module (linux.2.4.20) which contains a 2 mb static gloabal array. When I load it from linux booted via U-Boot system crashes. Everything works ok if I do the same thing with the same linux booted with RedBoot. Before loading the module I check the current meminfo and get the same result both times.

Some glue or something where and what to look?


Additional information:
The same error occurs if I just run depmod -a.

system: Avila board 64 MB RAM, ixdp425 architecture, U-Boot: 1.1.2

error message:
Unable to handle kernel paging request at virtual address e59f30f8 mm = c000a320 pgd = c3e60000 *pgd = 00000000, *pmd = 00000000 Internal error: Oops: 0
CPU: 0
pc 2 [<c0054f64>]    lr : [<00000000>]    Tainted: GF
sp : c3e45e94  ip : c3e45eb4  fp : c3e45eb0
r10: 00000000  r9 : c3e45f04  r8 : 00000004
r7 : 00000004  r6 : c016a000  r5 : c3e44000  r4 : e59f3054
r3 : e91ba870  r2 : c019cc70  r1 : 00000000  r0 : 00000000
Flags: nzCv  IRQs on  FIQs on  Mode SVC_32 Control: 39FF  Table: 03E60000
DAC: 00000015
Process klogd (pid: 89, stack limit = 0xc3e443a0)
Stack: (0xc3e45e94 to 0xc3e46000)

This SF.net email is sponsored by: 2005 Windows Mobile Application Contest Submit applications for Windows Mobile(tm)-based Pocket PCs or Smartphones for the chance to win $25,000 and application distribution. Enter today at http://ads.osdn.com/?ad_id=6882&alloc_id=15148&op=click
U-Boot-Users mailing list
U-Boot-Users at lists.sourceforge.net

More information about the U-Boot mailing list