[U-Boot-Users] Using at91 with a different parallel flash, request for help

Roman Kolesnikov romank at randrlabs.com
Mon Jun 12 21:07:29 CEST 2006

Marco Cavallini wrote:

> Roman Kolesnikov ha scritto:
>> Hello everyone,
>> I found the difference (with the help of Koan) in the command list 
>> and cycles for the newer Atmel chip. I have a new driver now to 
>> access the flash, and it works ok. However, I still have problem with 
>> UBoot1.1.4. When I load UBoot originally into flash and run, 
>> everything works well. However, when I restart the uboot from flash 
>> again, I think uboot overwrites something in the environment 
>> variables. My environment variables become corrupt. For instance the 
>> very first sign is invalid input, output, and debug settigns on the 
>> second start up.
>> When I print the environment variables, I get about 8K of garbage 
>> data. I wonder what could be causing my corruption. It only occurs in 
>> the environment variables.
> Hi Roman,
> Please show us your include/configs/at91rm9200dk.h
> Ciao

I think that my problem is in the driver. Here is why ->
I saved a linux kernel into flash from RAM.
I ran the kernel from RAM, it worked.
I reset and copied a kernel from flash iinto RAM.
I executed again, kernel did not work.

I think that the driver I wrote has problems.
I am working on it right now,

More information about the U-Boot mailing list